# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<mrn>\d{8}).*\s+(?P<lastname>\D+),(?P<firstname>\D+)\s+(?P<dob>[\d\/]{10})\s(?P<age>\w+)\s(?P<sex>\w)"
test_str = ("$\n"
"61731278 10141113787\n"
"Trauma,Test IV \n"
"01/01/1880 135Y M\n"
"7/27/2015\n"
"AC10141113787\\")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.