#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Set-Cookie:( ([^=\n]+)=([^;\n]+);)"
Local $sString = "Set-Cookie: CookieFirst=ValueFirst; expires=Tue, 01 Jan 2018 00:00:00 GMT; domain=.site.com; path=/; httponly" & @CRLF & _
"Set-Cookie: CookieSecond=ValueSecond; expires=Tue, 01 Jan 2018 00:00:00 GMT; domain=.site.com; path=/; httponly"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")