$re = '/Set-Cookie:( ([^=\n]+)=([^;\n]+);)/m';
$str = 'Set-Cookie: CookieFirst=ValueFirst; expires=Tue, 01 Jan 2018 00:00:00 GMT; domain=.site.com; path=/; httponly
Set-Cookie: CookieSecond=ValueSecond; expires=Tue, 01 Jan 2018 00:00:00 GMT; domain=.site.com; path=/; httponly';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);