// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Set-Cookie:( ([^=\n]+)=([^;\n]+);)").unwrap();
let string = "Set-Cookie: CookieFirst=ValueFirst; expires=Tue, 01 Jan 2018 00:00:00 GMT; domain=.site.com; path=/; httponly
Set-Cookie: CookieSecond=ValueSecond; expires=Tue, 01 Jan 2018 00:00:00 GMT; domain=.site.com; path=/; httponly";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}