const regex = /Set-Cookie:( ([^=\n]+)=([^;\n]+);)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Set-Cookie:( ([^=\\n]+)=([^;\\n]+);)', 'gm')
const str = `Set-Cookie: CookieFirst=ValueFirst; expires=Tue, 01 Jan 2018 00:00:00 GMT; domain=.site.com; path=/; httponly
Set-Cookie: CookieSecond=ValueSecond; expires=Tue, 01 Jan 2018 00:00:00 GMT; domain=.site.com; path=/; httponly`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}