using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*value1=\'(\d*)\'.*value2=\'\1\'.*";
string input = @"...somedata... value1='555', value2='666', ...somedata...
...somedata... value1='333', value2='333', ...somedata...
...somedata... value1='123', value2='456', ...somedata...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}