import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*value1=\\'(\\d*)\\'.*value2=\\'\\1\\'.*";
final String string = "...somedata... value1='555', value2='666', ...somedata...\n"
+ "...somedata... value1='333', value2='333', ...somedata...\n"
+ "...somedata... value1='123', value2='456', ...somedata...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}