const regex = /.*value1=\'(\d*)\'.*value2=\'\1\'.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*value1=\\\'(\\d*)\\\'.*value2=\\\'\\1\\\'.*', 'gm')
const str = `...somedata... value1='555', value2='666', ...somedata...
...somedata... value1='333', value2='333', ...somedata...
...somedata... value1='123', value2='456', ...somedata...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}