$re = '/.*value1=\'(\d*)\'.*value2=\'\1\'.*/m';
$str = '...somedata... value1=\'555\', value2=\'666\', ...somedata...
...somedata... value1=\'333\', value2=\'333\', ...somedata...
...somedata... value1=\'123\', value2=\'456\', ...somedata...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);