import re
regex = re.compile(r".*value1=\'(\d*)\'.*value2=\'\1\'.*", flags=re.MULTILINE)
test_str = ("...somedata... value1='555', value2='666', ...somedata...\n"
"...somedata... value1='333', value2='333', ...somedata...\n"
"...somedata... value1='123', value2='456', ...somedata...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")