# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=').*(?=')|\w+/\n/g;t' <<< "A,B,C,D,'1,2,3,4,5,6',E,F"