use strict;
my $str = 'A,B,C,D,\'1,2,3,4,5,6\',E,F';
my $regex = qr~(?<=').*(?=')|\w+~p;
my $subst = '\\n';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";