$re = '~(?<=\').*(?=\')|\w+~';
$str = 'A,B,C,D,\'1,2,3,4,5,6\',E,F';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;