import Foundation
let pattern = #"(?<=').*(?=')|\w+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"A,B,C,D,'1,2,3,4,5,6',E,F"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)