re = /(?<=').*(?=')|\w+/
str = 'A,B,C,D,\'1,2,3,4,5,6\',E,F'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result