#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?) (\d*)x(\d*)\s*(.*?) (\(\d*\))$"
Local $sString = "MasterChef Junior 3x03 Grandad Gordon! (2015)" & @CRLF & _
"Parks and Recreation 7x03 & 7x04 William Henry Harrison (2015)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")