const regex = /^(.*?) (\d*)x(\d*)\s*(.*?) (\(\d*\))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?) (\\d*)x(\\d*)\\s*(.*?) (\\(\\d*\\))$', 'gm')
const str = `MasterChef Junior 3x03 Grandad Gordon! (2015)
Parks and Recreation 7x03 & 7x04 William Henry Harrison (2015)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}