$re = '/^(.*?) (\d*)x(\d*)\s*(.*?) (\(\d*\))$/m';
$str = 'MasterChef Junior 3x03 Grandad Gordon! (2015)
Parks and Recreation 7x03 & 7x04 William Henry Harrison (2015)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);