re = /^(.*?) (\d*)x(\d*)\s*(.*?) (\(\d*\))$/m
str = 'MasterChef Junior 3x03 Grandad Gordon! (2015)
Parks and Recreation 7x03 & 7x04 William Henry Harrison (2015)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end