package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?) (\d*)x(\d*)\s*(.*?) (\(\d*\))$`)
var str = `MasterChef Junior 3x03 Grandad Gordon! (2015)
Parks and Recreation 7x03 & 7x04 William Henry Harrison (2015)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}