using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z0-9_\/\-]+)\/([a-z0-9_\-]+[\.]{1}(jpg|jpeg|png|gif))$";
string input = @"path/to/my-photo.jpeg";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}