re = /^([a-z0-9_\/\-]+)\/([a-z0-9_\-]+[\.]{1}(jpg|jpeg|png|gif))$/i
str = 'path/to/my-photo.jpeg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end