const regex = /^([a-z0-9_\/\-]+)\/([a-z0-9_\-]+[\.]{1}(jpg|jpeg|png|gif))$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z0-9_\\\/\\-]+)\\\/([a-z0-9_\\-]+[\\.]{1}(jpg|jpeg|png|gif))$', 'i')
const str = `path/to/my-photo.jpeg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}