$re = '/^([a-z0-9_\/\-]+)\/([a-z0-9_\-]+[\.]{1}(jpg|jpeg|png|gif))$/i';
$str = 'path/to/my-photo.jpeg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);