#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.bash_history-\d+\.tmp$"
Local $sString = "/home/vasya/..bash_history" & @CRLF & _
"/root/.bash_history" & @CRLF & _
"/root/.bash_history-124121.tmp" & @CRLF & _
"/root/.bash_history-124121.tmp" & @CRLF & _
"/root/.bash_history-124121.tmp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")