package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.bash_history-\d+\.tmp$`)
var str = `/home/vasya/..bash_history
/root/.bash_history
/root/.bash_history-124121.tmp
/root/.bash_history-124121.tmp
/root/.bash_history-124121.tmp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}