const regex = new RegExp('\\.bash_history-\\d+\\.tmp$', 'mg')
const str = `/home/vasya/..bash_history
/root/.bash_history
/root/.bash_history-124121.tmp
/root/.bash_history-124121.tmp
/root/.bash_history-124121.tmp`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}