$re = '`\.bash_history-\d+\.tmp$`m';
$str = '/home/vasya/..bash_history
/root/.bash_history
/root/.bash_history-124121.tmp
/root/.bash_history-124121.tmp
/root/.bash_history-124121.tmp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);