// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.bash_history-\d+\.tmp$").unwrap();
let string = "/home/vasya/..bash_history
/root/.bash_history
/root/.bash_history-124121.tmp
/root/.bash_history-124121.tmp
/root/.bash_history-124121.tmp";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}