package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(010002)[\s\S]*INTEREST`)
var str = `010002 D324Y56HY INTEREST
010002 SAD21 INTEREST`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}