const regex = /(010002)[\s\S]*INTEREST/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(010002)[\\s\\S]*INTEREST', 'gm')
const str = `010002 D324Y56HY INTEREST
010002 SAD21 INTEREST`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}