re = /(010002)[\s\S]*INTEREST/m
str = '010002 D324Y56HY INTEREST
010002 SAD21 INTEREST'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end