$re = '/(010002)[\s\S]*INTEREST/m';
$str = '010002 D324Y56HY INTEREST
010002 SAD21 INTEREST';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);