using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"src=""(.+)""";
string input = @"<div class=""wrapper"">
<ul>
<li><img src=""pervoe_img"" /></li>
</ul>
<div>
<img src=""vtoroe_img"" />
</div>
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}