import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src=\"(.+)\"";
final String string = "<div class=\"wrapper\">\n"
+ " <ul>\n"
+ " <li><img src=\"pervoe_img\" /></li>\n"
+ " </ul>\n"
+ " <div>\n"
+ " <img src=\"vtoroe_img\" />\n"
+ " </div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}