$re = '/src="(.+)"/';
$str = '<div class="wrapper">
<ul>
<li><img src="pervoe_img" /></li>
</ul>
<div>
<img src="vtoroe_img" />
</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);