// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"src="(.+)""#).unwrap();
let string = "<div class=\"wrapper\">
<ul>
<li><img src=\"pervoe_img\" /></li>
</ul>
<div>
<img src=\"vtoroe_img\" />
</div>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}