re = /src="(.+)"/
str = '<div class="wrapper">
<ul>
<li><img src="pervoe_img" /></li>
</ul>
<div>
<img src="vtoroe_img" />
</div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end