using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^deploy@\d+$";
string input = @"deploy@12134151
invalid matches
deploy@1234151a
Deploy@12341
deploy@@123141
deploy@1234.1234
deploy@12341-12
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}