re = /^deploy@\d+$/m
str = 'deploy@12134151
invalid matches
deploy@1234151a
Deploy@12341
deploy@@123141
deploy@1234.1234
deploy@12341-12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end