package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^deploy@\d+$`)
var str = `deploy@12134151
invalid matches
deploy@1234151a
Deploy@12341
deploy@@123141
deploy@1234.1234
deploy@12341-12
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}