import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^deploy@\\d+$";
final String string = "deploy@12134151\n\n"
+ "invalid matches\n"
+ "deploy@1234151a\n"
+ "Deploy@12341\n"
+ "deploy@@123141\n"
+ "deploy@1234.1234\n"
+ "deploy@12341-12\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}