use strict;
my $str = 'deploy@12134151
invalid matches
deploy@1234151a
Deploy@12341
deploy@@123141
deploy@1234.1234
deploy@12341-12
';
my $regex = qr/^deploy@\d+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}