import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'User'[_a-z0-9-]+(\\.[_a-z0-9-]+)*)@(?'Domain'[a-z0-9-]+(\\.[a-z0-9-]+)*\\.[a-z]{2,4})$";
final String string = "kevi.metal.maty.rock@goo.gle.ma.il.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}