$re = '/^(?\'User\'[_a-z0-9-]+(\.[_a-z0-9-]+)*)@(?\'Domain\'[a-z0-9-]+(\.[a-z0-9-]+)*\.[a-z]{2,4})$/i';
$str = 'kevi.metal.maty.rock@goo.gle.ma.il.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);