use strict;
my $str = 'kevi.metal.maty.rock@goo.gle.ma.il.com';
my $regex = qr/^(?'User'[_a-z0-9-]+(\.[_a-z0-9-]+)*)@(?'Domain'[a-z0-9-]+(\.[a-z0-9-]+)*\.[a-z]{2,4})$/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}