import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:((\\d+(?=[^.]+|\\.{2,})).)+|(\\d\\.){2,}).*|[^\\d]+$";
final String string = "1\n\n"
+ "1.7654\n\n"
+ "-2.5\n\n"
+ "2-\n\n"
+ "2...33\n\n"
+ "m\n\n"
+ "2..3\n\n"
+ "2....233..6\n\n"
+ "2.2.8\n\n"
+ "2--5\n\n"
+ "6-4-9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}