re = /^(?:((\d+(?=[^.]+|\.{2,})).)+|(\d\.){2,}).*|[^\d]+$/m
str = '1
1.7654
-2.5
2-
2...33
m
2..3
2....233..6
2.2.8
2--5
6-4-9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end