const regex = new RegExp('^(?:((\\d+(?=[^.]+|\\.{2,})).)+|(\\d\\.){2,}).*|[^\\d]+$', 'mg')
const str = `1
1.7654
-2.5
2-
2...33
m
2..3
2....233..6
2.2.8
2--5
6-4-9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}