import re
regex = re.compile(r"^(?:((\d+(?=[^.]+|\.{2,})).)+|(\d\.){2,}).*|[^\d]+$", flags=re.MULTILINE)
test_str = ("1\n\n"
"1.7654\n\n"
"-2.5\n\n"
"2-\n\n"
"2...33\n\n"
"m\n\n"
"2..3\n\n"
"2....233..6\n\n"
"2.2.8\n\n"
"2--5\n\n"
"6-4-9")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")